I was recently working on a Power BI project and I had uploaded my Power BI desktop file to the Power BI Service. I had then added an item to a newly created dashboard.

Determining why I could not use Q&A

When I went into the dashboard I did not see the option for the Q&A box as shown below, which I am typically used to seeing.

I then went into the Settings and clicked on the Dashboards tab, and then selected my associated dashboard above.

And this is what I saw when I tried to enable the Show the Q&A search box on this dashboard was the following: Q&A is not available for any of the datasets used on this dashboard.

So I went searching for quite a bit to try and understand how I can get this error resolved.

After broadening my search, I finally found the solution to my problem.

Problem Solved!

What I had done, in my Power BI Desktop file was to create a few Security Roles and published this to the service.

From my understanding currently Q&A does not support Row Level Security, so when it detects this it will disable the Q&A and when you try and enable it, it will give you the message as shown above.

To get Q&A working all that I did was to remove my Security Roles and re-publish the file.

And hey presto I got Q&A back!